Quake 4 v1.0.5 Beta Patch
The update is recommended for Windows users with Intel Hyper-Threading Technology (HT Technology) enabled processors, multiple processors, or systems with a dual core processor. The update is also required for Windows and Linux server admins as it addresses a recently identified problem with servers left unoccupied for very long periods of time (these servers will appear to be operating normally, but will crash clients that attempt to connect to them). This update will bring any previous version of the game (1.0.0 or 1.0.4) up to date and will not affect pure server, PunkBuster compatibility or protocol consistency.

id Software and Raven have worked with Intel to dramatically improve QUAKE 4 performance on systems with HT Technology, multiple processors, or dual core processors. Players who have a system with one of these configurations will notice performance gains in QUAKE 4 of anywhere from 25% - 87% depending on processor type. If you do not know whether or not you have a multi-processor, dual core, or HT Technology enabled system, please see the ReadMe file for simple instructions on checking your system. Please use the form at www.idsoftware.com/bugs/ to report any issues you find with the 1.0.5 update.

Finally, although we've released only small (but critical) updates to QUAKE 4 so far, we are working on a much broader update for release early next year, and we also have a couple of multiplayer map packs currently being tested for release in the near future. Stay tuned.
DEMOS
PATCHES - CHEATS
REVIEWS
GAME VIDEOS
NEWS ENTRIES
THIS WEEK'S MOST POPULAR DOWNLOADS