Pacific Fighters v3.03 Patch

The current version 3.03 (3.03m) is not compatible with the previous versions of the game when playing via network
Click on appropriate link to download the patch for your versions of Pacific Fighters - you need the full patch if you have installed the v3.0 of the game; if you have the v3.02 or v3.01, you have to download the incremental patch. The patches for the Forgotten Battles, Ace Expansion Pack and Pacific Fighters pack are also available. Press 'read more' for changelog.