Pacific Fighters v4.03 Patch

Versions 4.03 and 4.03m are not compatible with each other when playing over the network
Click on the appropriate link to download the patch for your versions of Pacific Fighters - the merged versions of the game (Forgotten Battles, Ace Expansion Pack and Pacific Fighters) are also available. The current version 4.03 (4.03m) is not compatible with the previous versions of the game when playing over the network (Online). Both the server and client must have the appropriate versions in order to connect. Press 'read more' for changelog.